`
jackchen0227
  • 浏览: 142715 次
  • 性别: Icon_minigender_1
  • 来自: 帝都
社区版块
存档分类
最新评论

joj 1062 Computer Versus Mankind 非递归最大公约数 最小公倍数

    博客分类:
  • ACM
 
阅读更多

 1062: Computer Versus Mankind


Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
3s 8192K 2437 1119 Standard

Mike is a fan on programming. He's sure that computer can do everything faster than mankind does if a kind of task is repeated certain amount of times. Now he is proving this conclusion by calculate the gcd and lcm of two positive integers a and b, where a,b>1.

The gcd of two positive integers a and b, where a,b>1, is the greatest common dividor of them. The lcm of two positive integers a and b, where a,b>1, is the least common multiple of them. For example, the gcd of 6 and 8 is 2 while the lcm of them is 24.

Input Specification

The input consists of multilines, each line consists of two integers a and b(0<a,b<231), separated by a single space. a=b=0 marks the end of input, which you shouldn't process.

Output Specification

For each pair a and b in the input, you should output the gcd and lcm on a single line, separated by a single space too.

Sample Input

6 8
5 2
0 0

Sample Output

2 24
1 10

 

Problem Source: 1st JOJ Cup Online VContest Warmup Problem

 

 

/*
	水题
 最大公约数,最小公倍数
 非递归版 gcd
*/

#include <stdio.h>
int m,n;
int gcd(int a,int b)
{
	int tmp;
	if(a < b)
	{
		tmp = a;
		a = b;
		b = tmp;
	}

	while(a % b != 0)
	{
		tmp = b;
		b = a % b;
		a = tmp;
	}
	return b;
}
int lcm(int a,int b)
{
	return a * b / gcd(a,b);
}
 int main()
 {
	while(scanf("%d %d",&m,&n),m != 0 && n != 0)
	{
		if(m == 0 || n == 0)
			break;
		printf("%d %d\n",gcd(m,n),lcm(m,n));
	}
	return 0;
 }
 
分享到:
评论

相关推荐

    joj 部分题目答案 自己做的 仅供参考

    joj 部分题目答案 自己做的 仅供参考 joj 部分题目答案 自己做的 仅供参考 joj 部分题目答案 自己做的 仅供参考 joj 部分题目答案 自己做的 仅供参考 joj 部分题目答案 自己做的 仅供参考

    joj上做的一些ACM试题

    在JOJ上做的一些ACM试题,都通过在线测试。

    joj.rar_joj

    本程序能实现操作系统中的先进先出页面置换算法

    joj acm 部分习题解答

    一些题目解答 1001-1012 自己做的,希望能帮助到一些朋友

    JOJ-jilin-university--acm.rar_joj

    可以为在JOJ上练习的同学做入门使用,这些代码全部通过。

    acm.rar_acm jlu 10_acm jlu 1029_joj 1237_joj10

    joj acm 源代码,即一些题得答案,方便大家联系参考。加油吧。

    JoJ-crx插件

    语言:Français Etre au courant quand JoJ est en live,策划人...约翰·奎因·伊斯特·布鲁和克林·德集团的非官方网站 Développéepar Azamir-倾倒fuclamation defonctionnalité,不满意的联系人Azamir#1089。

    吉林大学 joj 1000-2645题代码

    吉林大学 joj 1000-2645题代码,嘿嘿,大家就不用在花JPOINT买代码了,祝ACMer实现自己的心愿

    Joj - Java Version of Java-开源

    Joj 以与 JDOM 提供 XML 的 Java 表示类似的方式提供 Java 源代码的 Java 对象表示。

    joj 1424 硬币兑换问题

    硬币转化问题。用动态规划解决,不是很难。

    一个有关调度的问题joj1015

    这个题其实现在想起来也不知道是怎么就给ac的。

    吉林大学ACM题集.pdf-JOJ

    整理的ACM题集,吉林大学的,pdf格式,jilin univercity online judge system

    acm joj 1600

    关于大数取模的运算,比如说:a^b%m。下面提供2种解法。

    jovo-plugins:J Jovo框架插件

    插件 :star: Jovo插件插件使您可以轻松扩展Jovo Framework,而不必弄乱其核心代码和体系结构。 查看以了解如何创建自己的插件。插件清单要将您的插件添加到下表中,请分叉存储库,然后以与其他插件相同的格式将您的...

    JoJo-s-Bizarre-Survival:一个模组,将JoJo的奇异冒险中的看台添加到Minecraft

    该mod基于荒木飞吕彦的JoJo的奇妙冒险漫画和动漫系列。 这个mod也受到KnightDemon的1.12 mod 极大启发。 这个mod的目的是要从专营权中尽可能多地增加Minecraft,该mod目前仅包含Stand能力,其他能力(Hamon,...

    furystudios

    furystudios 普尔维·扎达塔克(Prvi zadatak) ...DroppingOff - radnikhodajućidolazi做pripadajuće科萨雷(izvedeno kroz provjeru tagova kutije)我卡达joj JE dovoljno blizu,fizičkiJE lan

    ControlEstoque_GH:..

    Este Projeto签证是由estoque进行的,它是由mer mercadorias uma determinada empresa sejam averiguadas和atualizadas ... 2021年1月20日,由JoséCláudiodeAraújoJúnior和Annielly Ferreira de Sousa所设计。

    大智慧最新安装

    大智慧最新安装包,老的已经过期不能查询个人自选股,所以推荐最新的大智慧给大家安装

Global site tag (gtag.js) - Google Analytics